Mail backup table overflow

Incident Report for Nexetic

Resolved

This incident has been resolved.
Posted Sep 20, 2025 - 12:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2025 - 12:21 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 19, 2025 - 14:18 UTC

Identified

Emails table has reached identity key capacity. We have copied the data to a new table, and we rebuilding indices to make the data accessible again.
No data loss, but mail backups, data view, and restores, are temporarily unavailable.
We expect to complete the process today.
Posted Sep 19, 2025 - 14:18 UTC
This incident affected: Nexetic Backup Microsoft 365 (Backups).